Network issues at the web server level
Incident Report for Harvest
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 21:13 UTC
Investigating
The team is currently investigating invalid network issues with Harvest, and will post a more detailed status update here as soon as possible.
Posted Apr 03, 2024 - 21:02 UTC
This incident affected: Harvest Application and API.