Harvest Disruption: Investigating Ongoing Issue

Incident Report for Harvest

Resolved

The issue is resolved.
Posted Mar 09, 2026 - 17:10 UTC

Update

The issue is resolved.
Posted Mar 09, 2026 - 17:10 UTC

Investigating

We are currently investigating the issue.
Posted Mar 09, 2026 - 17:01 UTC
This incident affected: Forecast Application, Harvest Activity Log, Harvest Application and API, Harvest Background Jobs, Harvest Email Service, Harvest Homepage, Harvest Mobile, and Harvest Third Party Integrations.